Raspberry Pi – via UMTS ins Netz – Konfiguration | Einstellungen

RaspberryPi_A_UMTS_D
Raspberry Pi Model A connected via UMTS!

Ich habe mir relativ günstig bei Ebay einen ‚Medionmobile‘ UMTS Stick ersteigert und zusätzlich bei Aldi ein Aldi Talk Starter-Paket gekauft.

Aldi bietet einen Tarif mit 150MB UMTS und danach GPRS Geschwindigkeit, für 3,99 im Monat und monatlich kündbar.
Es wird zwar ’nur‘ das Eplus Netz genutzt, aber das ist bei mir relativ gut verfügbar.

Kurzzusammenfassung: Was war nötig online zu gehen?

  1. wvdial installieren
  2. /etc/wvdial.conf anpassen
  3. ein zweizeiliges Bash Script für das Setzen der Simkarten PIN erstellen
  4. /etc/network/interfaces anpassen
  5. Verbindungsaufbau

1. wvdial installieren

pi@raspberrypi - $ sudo apt-get install wvdial
.
.
Success!  You can run "wvdial" to connect to the internet.
  (You can also change your configuration by editing /etc/wvdial.conf)
 
pi@raspberrypi - $

2. /etc/wvdial.conf anpassen

Dazu ist ein kleines bisschen Vorarbeit nötig.
Es ist wichtig den Pfad zu kennen, über den das UMTS Device angesprochen wird.
Nach dem Einstecken des Sticks – lsusb eingeben und sehen, ob der Stick erkannt wurde.

pi@raspberrypi ~ $ lsusb
Bus 001 Device 005: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270/E870 HSDPA/HSUPA Modem
pi@raspberrypi ~ $

Achtung: Bei der Raspberry Pi Model B hat es nicht funktioniert den Stick direkt an der Pi zu betreiben, da die Stromversorgung zusammengebrochen ist. Der Betrieb über einen USB-Hub ging aber problemlos. Das Model A hält es aus, wohl weil die von Haus aus selbst weniger Strom verbraucht.

Die letzten Einträge von var/log/messages, zeigen zu welchem Pfad das UMTS Modem hinzugefügt wird. In meinem Fall /dev/ttyUSB0.

Feb 20 15:17:26 raspberrypi kernel: [   10.527167] usb 1-1.3: new high-speed USB device number 5 using dwc_otg

. . Feb 20 15:17:26 raspberrypi kernel: [ 11.313066] usbcore: registered new interface driver option Feb 20 15:17:26 raspberrypi kernel: [ 11.323480] USB Serial support registered for GSM modem (1-port) Feb 20 15:17:26 raspberrypi kernel: [ 11.334289] option 1-1.3:1.0: GSM modem (1-port) converter detected Feb 20 15:17:26 raspberrypi kernel: [ 11.345030] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0 Feb 20 15:17:26 raspberrypi kernel: [ 11.354849] option 1-1.3:1.1: GSM modem (1-port) converter detected Feb 20 15:17:26 raspberrypi kernel: [ 11.375418] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1

Nun habe ich die /etc/wvdial.conf für meinen Aldi – Medionmobile Zugang konfiguriert.

pi@raspberrypi /etc $ cat wvdial.conf 
[Dialer Defaults]
Phone = 
Username = 
Password = 
New PPPD = yes
 
[Dialer eplus]
Modem = /dev/ttyUSB0
Phone = *99#
Username = eplus
Password = gprs
Init3 = AT+CGDCONT=1,"IP","internet.eplus.de","0.0.0.0"
ISDN=0
Auto Reconnect=on
Stupid Mode=off
Idle Seconds=0
Auto DNS=on

3. ein zweizeiliges Bash Script für das Setzen der Simkarten PIN erstellen

Wer seine SIM Karte mit einer Pin gesichert hat, muss vor der Einwahl dafür sorgen, dass die PIN dem UMTS Modem auch bekannt ist.
Dazu dient folgendes Bash Script:

pi@raspberrypi /usr/local/bin $ sudo cat setPIN.sh
#!/bin/sh
echo "AT+CPIN=4711\n\r" > /dev/ttyUSB0

Und jetzt noch so absichern, dass nur Root rein schauen darf

pi@raspberrypi /usr/local/bin $ ls -al
insgesamt 352
-rwx--x--x  1 root staff     50 Feb 24 13:14 setPIN.sh

4. /etc/network/interfaces anpassen

Zum Schluss kommen noch 4 Zeilen in die /etc/network/interfaces

pi@raspberrypi - $ sudo cat /etc/network/interfaces ab auto ppp0
auto lo
 
iface lo inet loopback
iface eth0 inet dhcp
 
auto ppp0
iface ppp0 inet wvdial
provider eplus
pre-up /usr/local/bin/setPIN.sh
 
allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

pre-up /usr/local/bin/setPIN.sh -> verweist auf das Script zur PIN Übergabe.

5. Verbindungsaufbau

Die Verbindung baut sich sofort nach dem booten automatisch auf, vorausgesetzt der Stick steckt.

Nachträglich kann die Verbindung mit folgenden Kommandos auf und abgebaut werden:

pi@raspberrypi - $ sudo ifup ppp0
pi@raspberrypi - $ sudo ifdown ppp0
Raspberry Pi – via UMTS ins Netz – Konfiguration | Einstellungen was last modified: Februar 22nd, 2017 by Henry Koch

33 Gedanken zu „Raspberry Pi – via UMTS ins Netz – Konfiguration | Einstellungen

  1. Hi, dank für die Anleitung. Das Thema ist bei mir etwas aus dem Ruder gelaufen. Das Problem war zunächst, dass der Stick nicht erkannt wurde. Nach Anpassungen klappte dies dann. Das nächste Problem war, dass für den Stick zwar der Internet S Tarif gebucht werden kann. Genutzt werden kann er im Stick jedoch nicht. Trotz Buchung und Belastung nimmt der Stick den Tarif nicht an und bucht stattdessen eine TAGESFLAT24. Die Rücksprache mit der Hotline ergab, dass der INTERNET S gar nicht über den WebStick genutzt werden kann, sondern NUR über Smartphone. Einzig der INTERNET XL Tarif für 14,95 ist hier nutzbar. Für gelegentlichen Internetzugriff des RasPI ist mir das jedoch zu teuer. Mal sehen welche Möglichkeiten es noch gibt.

    Gruß Michael

  2. Ich kenne mich mit den Tarifen nicht wirklich gut aus. Ich bezahle 3,99 Euro im Monat für einen Aldi Talk UMTS Volumentarif von 150 MB im Monat. Danach wird auf GPRS Geschwindigkeit reduziert. Die 150 MB reichen für meine Zwecke mehr als aus. Auch GPRS Geschwindigkeit würde genügen. Was natürlich Voraussetzung ist, ist das man EPLUS Empfang hat. Es geht aber auch mit anderen Anbietern. Z.Bsp. Fyve.de bietet 100 MB pro Monat für 5 Euro im D2 Netz an.
    Das der Surfstick mit der Raspberry Pi Online gehen kann, ist erwiesen. Das funktioniert bei mir seit März tadellos. Das Problem liegt wohl eher beim Provider der SIM Karte.

  3. Hallo und vielen Dank für die Schrittfür-Schritt-Anleitung!
    Leider wird mein Huawei Surfstick (auch eplus) als Ethernet-Device erkannt und nicht als GSM-Modem! Hast du eine Idee, wie ich da vorgehen könnte? Danke im Voraus!!
    Raimo

    PS: Hier der Ausschnitt aus den Log-Messages:
    Jun 1 18:27:20 raspberrypi kernel: [ 8564.951958] usb 1-1.2: new high-speed USB device number 9 using dwc_otg
    Jun 1 18:27:20 raspberrypi kernel: [ 8565.053423] usb 1-1.2: New USB device found, idVendor=12d1, idProduct=14db
    Jun 1 18:27:20 raspberrypi kernel: [ 8565.053456] usb 1-1.2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
    Jun 1 18:27:20 raspberrypi kernel: [ 8565.053472] usb 1-1.2: Product: HUAWEI HiLink
    Jun 1 18:27:20 raspberrypi kernel: [ 8565.053484] usb 1-1.2: Manufacturer: HUAWEI
    Jun 1 18:27:20 raspberrypi kernel: [ 8565.060062] cdc_ether 1-1.2:1.0: eth1: register ‚cdc_ether‘ at usb-bcm2708_usb-1.2, CDC Ethernet Device, 58:2c:80:13:92:63
    Jun 1 18:27:21 raspberrypi logger: usb_modeswitch: switched to 12d1:14db on 001/009

  4. Vielen Dank für Deine Klasse Anleitung!

    Eine Frage habe ich … kannst Du Dir erklären, warum bei mir am Model A mit aktiven Hub der WLAN-Stick abgeschaltet wird, sowie das Modem (S4011) eine Verbindung herstellt? Hab alles so konfiguriert, wie Du es hier erklärt hast …

    Gruß,
    Sandy.

    • Der beschriebene Verbindungsaufbau ist so konfiguriert, dass die UMTS Karte die Internetzvebindung aufbaut, sobald sie aktiv wird.
      Das ist im Schritt 4 ‚/etc/network/interfaces anpassen‘ eingebaut.
      Da dein Rechner in der Regel nur eine IP Adresse nach außen hat, ist auch nur eine Netzwerkverbindung zur selben Zeit aktiv. Das bedeutet, sobald UMTS dazu kommt, ist WLAN raus.
      Dieses Verhalten kannst du verhindern, indem du die Verbindung manuell aufbaust und somit auf den ‚Service‘ innerhalb der /etc/network/interfaces verzichtest. Das wären dann die letzten beiden Befehle in dem Artikel: sudo ifup ppp0 | sudo ifdown ppp0

  5. Hi, super Erklärung! Eine Frage: Bei mir wird bei Einwahl über PPP (UMTS-Stick) die Systemuhrzeit des RPi nicht aktualisiert (kein NTP). Woran kann das liegen, bzw. gibt es hierzu Lösungen? Danke. Beste Grüße Stefan

    • Ja da bin ich auch darüber gestolpert.
      Die Raspberry Pi hat keine eingebaute Systemuhr.
      Beim Bootvorgang wird eine aktive Netzverbindung vorausgesetzt und sich über die Verbindung die Systemzeit von einem NTC Server gezogen.
      Es gibt kleine Zusatzmodule, die die Systemzeit ohne Netzwerkverbindung bereitstellen.
      Ich habe da zwei liegen, aber noch nicht eigebaut, so dass ich auch noch nichts zu sagen kann.
      Hier ist einer der vielen Links wie man das RTC Modul zum Laufen bringt: http://learn.adafruit.com/adding-a-real-time-clock-to-raspberry-pi/wiring-the-rtc.
      Sicherlich gibt es eine Möglichkeit die NTC Abfrage gleich nach dem die Netzwerkverbindung per UMTS aktiv ist nochmal machen kann.
      Habe ich ehrlich gesagt noch nicht versucht. – Sollte es aber mal tun :-)

        • Danke für die Info!
          Das werde ich gleich mal ausprobieren.
          Dann würde es auch Sinn machen direkt auf der PI via MySQL Daten zu sammeln und mit GNUPlot o.ä. zu Grafiken bauen zu lassen.
          Mir fehlte dazu bisher der Zeitbezug.

    • Ich verstehe die Frage nicht wirklich. Aus Betriebssystemsicht ist es doch nicht unbedingt wichtig welches Gerät die Verbindung ins Netz eröffnet. Hauptsache Sie ist da. Was soll es bringen eine UMTS Karte, wie eine kablegebundene Ethernetkarte anzustreichen?

  6. Hallo Henry,
    danke für die Hinweise!

    Ich überlege mir auch einen Raspberry Pi zuzulegen und würde ihn auch gerne per Surfstick betreiben. Dazu habe ich noch eine Frage: Du schreibst, dass der direkte Anschluss des Surfstick an das Raspberry Pi Model B nicht funktionierte und die Stromversorgung zusammenbrach.
    Meinst Du, man kann das Problem „einfach“ lösen, indem man ein stärkeres Netzteil an den Pi anschließt oder ist es eher wahrscheinlich, dass auf der Platine der Strom nicht hinreichend weitergeleitet werden kann, um einen Surfstick über die beiden USB-Stecker an der Platine direkt (d. h. ohne Hub mit eigener Zusatzstromversorgung) zu versorgen? Ziel der Fragestellung: Raspberry Pi B mit Surfstick ohne zweiten Stecker für ein Hub betreiben…

    Würde mich auch schon über eine qualifizierte Spekulation zum Thema freuen…

    Viele Grüße
    Threx

    • Hallo Threx,
      ich gehe stark davon aus, dass ein stärkeres Netzteil das Problem lösen wird.
      Ich habe ein Netzteil, was zum Laden eines Samsung Telefons gedacht ist verwendet und das hat 5V 700mA, was nicht all so sehr viel ist.
      Die Pi, die ich in meiner Garage betreibe, um Energiedaten zu verarbeiten, wird von einem DC DC Wandler direkt über eine 12V Autobatterie betrieben.
      Dort habe ich noch nicht festgestellt, dass es zu einem Spannungsabfall kommt.
      Sicherlich gibt es auch Surfsticks, die von Hause aus weniger Strom verbrauchen.
      Es kommt auf einen Versuch an.
      Ich würde es mit einem stärkeren Netzteil probieren und sehen was passiert.
      Schau wir mal, dann sehn wir’s schon :-)

    • Ich betreibe den Pi mit einem 2A Netzteil (modernes Handyladegerät) und kann damit gleichzeitig einen Edimax-WLAN-Stick (max 500mA) und einen Huawei-UMTS-Stick (ebenfalls max 500 mA) betreiben.

      Die angegebene maximale Stromaufnahme findet man übrigens mit sudo lusb -v

    • Hallo Simo,
      die Pi hat werkseitig 2 USB Ports und die kleine Version ohne Ethernetanschluß hat einen USB Port.
      Mit einem USB Hub läßt sich das nicht beliebig, aber doch sehr erweitern.
      Jedes eingesteckte USB Gerät wird vom System erkannt, oder muß dem bekannt gemacht werden.
      Es sollte also möglich sein auch 2 UMTS Sticks parallel an die PI zu stecken.
      Online gehen wird es aus meiner Sicht aber nur über eine Vebindung funktionieren, also nicht parallel.
      Grüsse Henry

  7. Hallo Henry,
    ich versuche jetzt schon seid 4 Monaten meinen Pi über das UMTS Modem online zu bekommen. Ich habe das Huawei E270 Modem und schon alle möglichen wvdial.conf aus dem internet ausprobiert. Über Ubuntu 12. und 13 klappt der Verbindungsaufbau über den networkmanager einwandfrei. Leider nicht bei dem Raspberry. Das einzige was mir angezeigt wird ist die NO CARRIER Meldung. Das erste mal nach dem Neustart findet das modem den Carrier, verliert die Verbindung und kehrt zu dem NO CARRIER Trying again zurück. So langsam weiß ich nicht mehr weiter :D Config, und Anbieter sind die selben. Wheezy sogar schon neu auf dem Raspberry installiert und nach der Installation direkt wvdial installiert.. Leider selbes Ergebnis irgend einen Rat ?

  8. Hallo zusammen, ich versuche vergeblich seit Monaten mit meinem Raspberry über ein Huawei E270 Umts Modem online zu gehen. Ich habe schon diverse wvdial.conf aus dem Internet mit den Daten von eplus gefüttert aber leider nur mit Teilerfolg. Ich bekomme unter Ubuntu 12 Ubuntu und 13 mit dem installierten Networkmanager ohne Probleme eine Verbindung. Andererseits über wvdial nur das Modem initialisiert. Sobald die Verbindung aufgebaut werden soll findet das Modem keinen Carrier. Pin von der Simkarte ist abgeschaltet. weiß jemand einen Rat oder sollte ich ein anderes Modem ausprobieren ?

    • Hallo Stephan,
      das erste was mir einfällt, ist das evtl die Spannung zusammenbricht, wenn der UMTS Stick online gehen will. Hast Du / Haben Sie schonmal versucht einenaktiven USB Hub zwischen Raspberry Pi und den UMTS Stick zu hängen?
      Ich hatte das Problem am Anfang, dass die Energie meines Handyladegerätes nicht ausreichte.
      Sollte es mit aktiven USB Hub auch nicht gehen, wird es nötig etwas tiefer in die Konfiguration abzutauchen.
      Nach der Schilderung vermute ich das Problem bei der Übergabe des Pin’s.
      Möglicherweise wurde die Deaktivierung der Pin Abfrage nicht von jeder Komponente asl solche verstanden.
      Grüsse Henry

  9. Zunächst mal sorry wegen dem doppel post. Die Spannungsversorgung läuft über einen Aktiven Hub und der Pincode der Sim Karte ist ausgeschaltet. Unter Ubuntu 12 und 13 bekomme ich den Webstick nur über den installierten Networkmanager ans laufen. Unter beiden Betriebssystemen leider nicht über Wvdial.

  10. SURFSTICK:
    Also ich habe festgestellt, dass die Surfsticks sehr verschieden sind.

    Wer hat mit welchen Surfsticks denn Erfolg gehabt. Da die Dinger nicht billig sind, würde man so schneller ans Ziel kommen.

    Der Huawei E173 – funktioniert der am PI? Die meisten Router die ich gekauft hatte, kamen damit nicht zurecht.

  11. Moin Moin,

    schöne Darstellung.
    Ich habe mir einen web n walk Stick zugelegt, wegen der schlechte Netzabdeckung in meinem Wohnort. Mein Raspberry B erkennt diesen aber nicht. Mit lsusb taucht er nicht auf. wvdial berichtete gleich nach dem Setup eine Fehlverbindung und verwies mich auf wvdial.conf. Der Stick ist CDFS formatiert, könnte das der Grund sein?

    alle Gute
    Boris

  12. Hallo,
    dank der guten Anleitung habe ich alles so konfiguriert, dass mein Huawei Stick zumindest angesprohen wird und auch den Carrier entdeckt.

    leider verliert er das Signal (siehe Terminal Output unten )

    Hab ich da irgendwas in der config (siehe ganz unten) falsch gemacht ?

    Ich gehe über o2 postpaid ins Internet

    Bin um jeden Tip dankbar

    Franz Otto

    Terminal output:
    ************************Beginn*****************
    pi@raspberrypi ~ $ wvdial o2
    –> WvDial: Internet dialer version 1.61
    –> Cannot set information for serial port.
    –> Initializing modem.
    –> Sending: ATZ
    ATZ
    OK
    –> Sending: AT+CGDCONT=1,“IP“,“internet“,“0.0.0.0″
    AT+CGDCONT=1,“IP“,“internet“,“0.0.0.0″
    OK
    –> Modem initialized.
    –> Sending: ATDT*99#
    –> Waiting for carrier.
    ATDT*99#
    CONNECT
    –> Carrier detected. Waiting for prompt.
    –> Connected, but carrier signal lost! Retrying…
    –> Sending: ATDT*99#
    –> Waiting for carrier.
    ^BOOT:23260771,0,0,0,64
    ATDT*99#
    NO CARRIER
    –> No Carrier! Trying again.
    –> Sending: ATDT*99#
    –> Waiting for carrier.
    ATDT*99#
    NO CARRIER
    –> No Carrier! Trying again.
    –> Sending: ATDT*99#
    ******************Ende Output*****************
    config Datei :

    ***********************Beginn**********************
    wvdial.conf[Dialer Defaults]
    Phone =
    Username =
    Password =
    New PPPD = yes

    [Dialer o2]
    Modem = /dev/ttyUSB1
    Phone = *99#
    Username =
    Password =
    Init1 = ATZ
    #Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    Init3 = AT+CGDCONT=1,“IP“,“internet“,“0.0.0.0″
    Phone = *99#
    Username = { }
    Password = { }
    Stupid Mode = 1
    ISDN = 0
    Auto Reconnect=on
    Stupid Mode=off
    Idle Seconds=0
    Auto DNS=on
    ******************Ende Config*************

    • Das war auch mein Problem. Habe einen Surfstick ZTE 190MF (19d2:0117 ZTE WCDMA Technologies MSM )

      Dieser Stick meldet laut dmesg 3 Devices an (ttyUSB0, ttyUSB1 und ttyUSB2) letzteres muss benutzt werden und die üblichen wvdial-Init-Strings müssen weggelassen werden. Meine wvdial.conf für O2 Netzclub:

      [Dialer Defaults]
      New PPPD = yes
      Modem = /dev/ttyUSB2

      [Dialer netzclub]
      Stupid mode = on
      Init3 = AT+CGDCONT=1,“IP“,“pinternet.interkom.de“
      Auto DNS = on
      Idle Seconds=0
      ISDN=0
      Password = internet
      Auto Reconnect = off
      Username = internet
      Phone = *99#

  13. Hallo leute. Erstmal, guter Beitrag!
    Leider habe ich das problem mit wvDial, dass ich der bei mir keine IP bekommt…
    Nach dem aufruf von wvDial bekomme ich folgendes:

    No CARRIER

    Call Ready
    CONNECT
    –> Carrier detected. Starting PPP immeadialey.
    –> Starting pppd at Fri May 9 15:17…
    –> Pid of pppd: 2272

    So und das wars, eigentlich sollte er mir jetzt hier, nach dem er einen Carrier gefunden hat, eine IP abrufen und mir des auch ausgeben.
    Leider ist danach aber Schluss und es läuft nichts mehr.
    Muss man in der Netzwerkeinstellung noch was anpassen, damit er eine ppp verbindung aufbauen kann?

    Vielen Dank,
    Luke

  14. hallo danke für deine Anleitung.
    doch leider nichts.

    hier die fehler und kernel:
    wo liegt der fehler ?

    Kernel
    Dec 8 19:11:39 www3 kernel: [ 783.791383] usb 1-1.3: Product: ZTE WCDMA Technologies MSM
    Dec 8 19:11:39 www3 kernel: [ 783.791398] usb 1-1.3: Manufacturer: ZTE,Incorporated
    Dec 8 19:11:39 www3 kernel: [ 783.791411] usb 1-1.3: SerialNumber: P671A2TMED010000
    Dec 8 19:11:39 www3 kernel: [ 783.795959] usb-storage 1-1.3:1.3: USB Mass Storage device detected
    Dec 8 19:11:39 www3 kernel: [ 783.800404] scsi2 : usb-storage 1-1.3:1.3
    Dec 8 19:11:39 www3 kernel: [ 783.892512] usbcore: registered new interface driver usbserial
    Dec 8 19:11:39 www3 kernel: [ 783.892642] usbcore: registered new interface driver usbserial_generic
    Dec 8 19:11:39 www3 kernel: [ 783.892746] usbserial: USB Serial support registered for generic
    Dec 8 19:11:39 www3 kernel: [ 783.951147] usbcore: registered new interface driver option
    Dec 8 19:11:39 www3 kernel: [ 783.951347] usbserial: USB Serial support registered for GSM modem (1-port)
    Dec 8 19:11:39 www3 kernel: [ 783.952120] option 1-1.3:1.0: GSM modem (1-port) converter detected
    Dec 8 19:11:39 www3 kernel: [ 783.960187] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0
    Dec 8 19:11:39 www3 kernel: [ 783.960640] option 1-1.3:1.1: GSM modem (1-port) converter detected
    Dec 8 19:11:39 www3 kernel: [ 783.970794] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1
    Dec 8 19:11:39 www3 kernel: [ 783.971239] option 1-1.3:1.2: GSM modem (1-port) converter detected
    Dec 8 19:11:39 www3 kernel: [ 783.972577] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB2
    Dec 8 19:11:40 www3 logger: usb_modeswitch: switched to 19d2:0117 on 001/007
    Dec 8 19:11:40 www3 kernel: [ 784.800468] scsi 2:0:0:0: Direct-Access ZTE MMC Storage 2.31 PQ: 0 ANSI: 2
    Dec 8 19:11:40 www3 kernel: [ 784.803904] sd 2:0:0:0: [sda] Attached SCSI removable disk
    Dec 8 19:11:40 www3 kernel: [ 784.803996] sd 2:0:0:0: Attached scsi generic sg0 type 0

    ####################

    pi@www3 ~ $ cd /dev/
    pi@www3 /dev $ ls -la |grep ttyUSB
    lrwxrwxrwx 1 root root 7 Dez 8 19:11 gsmmodem -> ttyUSB2
    crw-rw—T 1 root dialout 188, 0 Dez 8 19:11 ttyUSB0
    crw-rw—T 1 root dialout 188, 1 Dez 8 19:11 ttyUSB1
    crw-rw—T 1 root dialout 188, 2 Dez 8 19:11 ttyUSB2

    root@www3:/var/log# ifup ppp0
    /usr/local/bin/setPI.sh: 2: /usr/local/bin/setPI.sh: gt: not found
    AT+CPIN=****

    /usr/local/bin/setPI.sh: 2: /usr/local/bin/setPI.sh: /dev/ttyUSB2: Permission denied
    Failed to bring up ppp0.
    root@www3:/var/log#

    root@www3:/etc# lsmod
    Module Size Used by
    option 28349 0
    usb_wwan 8408 1 option
    usbserial 26684 2 option,usb_wwan

    root@www3:/var/log# lsusb zte MF190 von >O2
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 007: ID 19d2:0117 ZTE WCDMA Technologies MSM

    root@www3:/var/log# wvdial o2
    –> WvDial: Internet dialer version 1.61
    –> Initializing modem.
    –> Sending: ATZ
    ATZ
    OK
    –> Sending: AT+CGDCONT=1,“IP“,“pinternet.interkom.de“,“0.0.0.0″
    AT+CGDCONT=1,“IP“,“pinternet.interkom.de“,“0.0.0.0″
    ERROR
    –> Bad init string.
    –> Initializing modem.
    –> Sending: ATZ
    ATZ
    OK

    Vielleicht seht ihr was ?

  15. In der setPIN.sh muß zwischen dem CPIN-kram (in Anführungszeichen) und /dev/ttyUSB0 ein Größerzeichen sein, nicht „KaufmännischesUnd g t Semikolon“, da hat mal wieder jemand html-escaping vermurkst. ;)
    Das AT+CGDCONT schlägt dananch nur fehl, weil die pin halt noch nicht eingegeben wurde.

  16. Ich bin nicht mal soweit gekommen – wie in der Anleitung beschrieben. Bei mir ist schon die Installation von vwdial nicht machbar, er bricht bei mletzten Punkt der Konfiguration ab und landet im Nirvana.
    Hate einer von euch beim Raspberry auch den Hänger bei der Installation gehabt ?

    Hat jemand eine Ahnunbg was da falsch läuft ?
    Gruss Kasi

  17. Es gibt vom Netzclub (www.netzclub.de) eine kostenlose Prepaid-SIM mit 100MB Highspeed-Traffic im Monat. Finanziert wird das durch Werbe-SMS und -Emails, aber ich persönlich finde das bei dem ganzen sonstigen Spam und einem gut angelernten Spamfilter nicht schlimm. Habe die Karte jedoch (bisher ;) ) nur in meinem Smartphone ausprobiert…

  18. Hallo, danke auch von mir für die tolle Anleitung. Ich habe mit dem ALDI TALK Webstick (MD 99079) und einen ALDI TALK Internet Flat S Tarif.

    Ich habe sie so auf einem Hummingboard Base mit Debian Jessie umgesetzt, allerdings endet das Wählen mit einem Fehler:

    root@mohot:~# wvdial eplus
    –> WvDial: Internet dialer version 1.61
    –> Initializing modem.
    –> Sending: ATZ
    ATZ
    OK
    –> Sending: AT+CGDCONT=1,“IP“,“internet.eplus.de“,“0.0.0.0″
    AT+CGDCONT=1,“IP“,“internet.eplus.de“,“0.0.0.0″
    OK
    –> Modem initialized.
    –> Sending: ATDT*99#
    –> Waiting for carrier.
    ATDT*99#
    ERROR
    OK
    –> Invalid dial command.
    –> Disconnecting at Fri Dec 9 12:23:44 2016
    root@mohot:~#

    Ich habe das Setup auch schonmal mit pppd und chatscripten probiert, ich laufe aber in genau denselben Fehler.

    Hast Du sowas mal gesehen? Hast Du irgendeine Idee, was da schief gehen könnte?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.